Resolved
502 Bad Gateway errors

Started
May 12, 2023 at 17:44
Status
Resolved after about 3 hours

Impact

Partial outage
Affected
Deno Deploy
Edge Network
  • Resolved

    This incident has been resolved.

  • Monitoring

    We've identified + rolled back the change that caused the issue.

    The cause of this downtime was a change of behavior in the dotenv module after we enabled some additional features in Deno Deploy.

  • Investigating

    We're seeing a number of 502 bad gateway errors being served erroneously from Deno Deploy. We're currently investigating the root cause.