Deno - Deno Deploy - Intermittent Service Degradation – Incident details

Deno Deploy - Intermittent Service Degradation

Resolved
Degraded performance
Started 7 days agoLasted 2 days

Affected

Deno Deploy

Degraded performance from 5:48 PM to 2:49 PM

Edge Network

Degraded performance from 5:48 PM to 2:49 PM

Updates
  • Resolved
    Resolved

    This incident has been confirmed to be resolved since yesterday, October 1st, 2025 at around 18:00 UTC after an infrastructure patch has been rolled out.

  • Investigating
    Investigating

    We are currently investigating an incident that is impacting intermittently a subset of apps running in the Deno Deploy platform. The issue is restricted to apps that are using the Web Cache API.

    This incident is not impacting apps running in Deno Deploy Classic.