Deno - Degraded performance on Deno Deploy โ€“ Incident details

Experiencing partially degraded performance

Degraded performance on Deno Deploy

Monitoring
Major outage
Started about 16 hours ago

Affected

Deno Deploy

Partial outage from 9:32 PM to 9:41 PM, Degraded performance from 9:41 PM to 12:00 AM

Console

Partial outage from 9:32 PM to 9:41 PM, Degraded performance from 9:41 PM to 12:00 AM

Managed Network

Partial outage from 9:32 PM to 9:41 PM, Degraded performance from 9:41 PM to 12:00 AM

Module Registry

Partial outage from 9:32 PM to 9:41 PM, Degraded performance from 9:41 PM to 12:00 AM

cdn.deno.land

Partial outage from 9:32 PM to 9:41 PM, Degraded performance from 9:41 PM to 12:00 AM

deno.land/std import

Partial outage from 9:32 PM to 9:41 PM, Degraded performance from 9:41 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    The storage connectivity issue in our Chicago (ord) region has resolved. Traffic has been restored to ord and requests are being served normally. Builds are operational. We are monitoring the cluster for any remaining issues.

  • Identified
    Identified

    We have identified the issue as a storage connectivity problem in our Chicago (ord) region. Traffic has been rerouted to our Amsterdam (ams) region and requests are now being served successfully. Builds may still be affected. We are continuing to work with our infrastructure provider on the underlying issue.

  • Investigating
    Investigating

    We are investigating degraded performance affecting Deno Deploy. Some deployments routed through our Chicago (ord) region are experiencing boot failures and elevated error rates due to an upstream storage connectivity issue.

    Deployments served by other regions are unaffected.

    We are working with our infrastructure provider to resolve the issue and will post updates as they become available.