Deno - Intermittent Request Failures – Incident details

Intermittent Request Failures

Resolved
Degraded performance
Started 2 months agoLasted 32 minutes

Affected

Deno Deploy

Degraded performance from 5:43 PM to 6:15 PM

Managed Network

Degraded performance from 5:43 PM to 6:15 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

    The internal service mesh has seen handshake failures between some nodes and we have implemented mitigation measures. We're investigating the root cause for a final fix.

  • Investigating
    UTC
    Investigating

    We are currently investigating this incident.

    We're seeing again some requests failing with 503 errors with the message `NO_VALID_CLUSTER`