Deno - Deno Deploy Chicago cluster outage – Incident details

Deno Deploy Chicago cluster outage

Resolved
Major outage
Started about 4 hours agoLasted about 1 hour

Affected

Deno Deploy

Major outage from 4:25 PM to 5:15 PM

Managed Network

Major outage from 4:25 PM to 5:15 PM

Websites

Major outage from 4:25 PM to 5:15 PM

deno.land

Major outage from 4:25 PM to 5:15 PM

deno.com

Major outage from 4:25 PM to 5:15 PM

Updates
  • Monitoring
    Monitoring
    The Chicago cluster outage was resolved around 10:15 PDT and affected services have recovered. We are continuing to monitor.
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    Starting around 09:25 PDT, the Deno Deploy Chicago cluster experienced an outage. This affected the Deno Deploy managed edge network for visitors routed through that region, impacting a significant portion of global traffic. Because deno.land and deno.com are hosted on Deno Deploy, they were affected as well. The Deno Deploy console remained available, but builds triggered via GitHub integration, CLI, or API were failing because builds run in Chicago. Sandbox creation in Chicago was also failing.