Deno - Issues with API calls – Incident details

Issues with API calls

Resolved
Major outage
Started 5 days agoLasted about 2 hours

Affected

Deno Deploy

Major outage from 11:00 AM to 1:20 PM

API

Major outage from 11:00 AM to 1:20 PM

GitHub Integration

Major outage from 11:00 AM to 1:20 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    Due to sporadic failures in our API service, many API calls are spuriously failing. Particularly long running API calls are affected, such as builds triggered from GitHub Actions. We have found the root cause, and are working on a fix.