Deno - Intermittent Build Failures on Early Access – Incident details

Intermittent Build Failures on Early Access

Resolved
Degraded performance
Started 9 months agoLasted 5 days

Affected

Deno Deploy

Degraded performance from 10:21 PM to 10:31 AM

Console

Degraded performance from 10:21 PM to 10:31 AM

Managed Network

Degraded performance from 10:21 PM to 10:31 AM

Deno Deploy Classic

Operational from 10:21 PM to 10:31 AM

API

Operational from 10:21 PM to 10:31 AM

Dashboard

Operational from 10:21 PM to 10:31 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

    If you encounter any build failures or slow builds, please reach out to deploy@deno.com.

  • Monitoring
    UTC
    Monitoring

    Deno Deploy continues to see failed builds, slow response times, and occasional 500 errors. These are the result of an ongoing maintenance project aimed at improving the long-term reliability of Deno Deploy.

    Our team is actively working to stabilize the system.

  • Identified
    UTC
    Identified

    We are still tracking down issues with builds. We expect the situation to persistent until tomorrow, October 23rd.

  • Investigating
    UTC
    Investigating
    We are currently investigating this incident.