Resolved
Partial outage of Deno KV

Started
September 09, 2023 at 02:54
Status
Resolved after less than a minute

Impact

Operational
Affected
Deno Deploy
KV
  • Resolved
    Resolved

    This incident has been resolved.

    Due to a protocol change, remote writes to hosted Deno KV databases between 2023-09-07 08:45 and 2023-09-09 02:54 (UTC) were expired immediately.

    This affects Deno CLI users who used a new feature to connect to hosted KV databases from outside Deno Deploy. Projects hosted on Deno Deploy were not affected.

    We have continuous backup during the period of the outage. If you experienced data loss after overwriting production data from CLI, please reach out to us.