TLS certificates are not automatically renewed for some custom domains

Resolved
Degraded performance
Started 21 days ago Lasted about 6 hours

Affected

Deno Deploy
Edge Network
Updates
  • Resolved
    Resolved

    The service has now been fully restored.

  • Monitoring
    Monitoring

    We implemented a fix and all custom domain services are recovering. At peak, 200 domains were temporarily impacted. A full recovery is expected within 10 to 15 minutes.

  • Investigating
    Investigating
    We are currently investigating this incident.