Deno - Degraded service on Deploy – Incident details

Degraded service on Deploy

Resolved
Operational
Started about 2 months agoLasted about 7 hours

Affected

Deno Deploy

Operational from 10:59 AM to 5:51 PM

Edge Network

Operational from 10:59 AM to 5:51 PM

Websites

Operational from 10:59 AM to 5:51 PM

deno.land

Operational from 10:59 AM to 5:51 PM

deno.com

Operational from 10:59 AM to 5:51 PM

Updates
  • Resolved
    Resolved

    The service degradation of Deploy impacted the following two regions:

    • Southeastern Asia between 10:59 and 11:03 UTC with less than 8% of traffic affected

    • Eastern South America between 11:05 and 11:21 UTC with less than 17% of traffic affected

    This occurrence did not impact any of the other global regions.

    The impact was felt during a service transition period into a new release that was being deployed at the time. This type of impact is not expected and we continue investigating the root cause at this stage. We will be implementing system improvements to ensure that similar situations in the future are prevented.

  • Monitoring
    Monitoring

    There was some service degradation on Deploy between 10:59 and 11:23 UTC causing intermittent 502 HTTP errors and longer load times. The issue was caused by some instability on the runtime infrastructure during a production rollout. The root cause is currently under investigation.