Resolved
Edge Functions and Module Registry unavailable

Started
May 23, 2023 at 20:47
Status
Resolved after about 1 hour

Impact

Major outage
Affected
Deno Deploy
API
Dashboard
Edge Network
GitHub Integration
Module Registry
api.deno.land/modules
deno.land/std import
deno.land/x import
api.deno.land/modules/std
Websites
deno.com
deno.land
  • Resolved

    We identified and rolled back the change that caused the outage. We're still investigating the root cause, but right now it looks like a fairly innocent change to enable system and scheduler logging on our GKE clusters resulted in pods not being able to be scheduled. Our apologies for the inconvenience.

  • Investigating

    As part of a bad rollout, we're seeing failing requests in multiple regions. Currently working on rolling back.